1. We are a group of vapers dedicated to all things rebuildable. We have a solid user base of experienced rebuilders who enjoy sharing our knowledge and learning from each other. We have a healthy mix of cloud chasers, flavor chasers, temp control, and kanthal builders. We also have a broad base of knowledge on mods, batteries, and toppers. Please consider joining us and contributing to our community. Whether you are here to teach or to learn, we welcome your participation and look forward to chasing that perfect vape together.

Cool fireIV TC issue

Discussion in 'Temp Control' started by skybbc, Jun 20, 2016.

  1. skybbc

    skybbc New Member

    Joined:
    Jun 8, 2016
    Messages:
    4
    Likes Received:
    3
    hi,guys,recently i got one Innokin Cool Fire IV TC100,i use the ss 0.5ohm coils and set the temp cotnrol to 400F,why we got burning smell,but it never happen on cuboid 150w....

    any sugguestion?
     
  2. trlrtrash13

    trlrtrash13 The trash of thy trailer.
    Staff Member

    Joined:
    Nov 28, 2015
    Messages:
    2,113
    Likes Received:
    1,219
    I assume you made sure you were in SS mode? I don't do much TC but maybe @Snert or @Yankifenix might have a suggestion.
     
  3. Snert

    Snert Administrator
    Staff Member REFugee

    Joined:
    Nov 29, 2015
    Messages:
    913
    Likes Received:
    750
    I don't have any specific experience with the Cool Fire IV but, in general, there are a couple of reasons you could get a burnt taste with a TC mod.

    1) Bad coil

    This can have two causes. There could be a bad insulator that slipped through Quality Control (happens on occasion). Vapors experience that a lot in the early days of the Vivi Nova type heads. It could also be that the SS wire inside the coil isn't making good contact. TC mods are designed (for the "convenience" of swapping from TC to non-TC coils) to slip back into power mode if the resistance of the wire doesn't change as expected. This will be very noticeable at higher wattage settings.

    Possible solution: Try a couple of new coils. It is possible there could be more than one bad coil in a batch.

    2) Defective tank

    You'll see the same behavior as with a bad coil, but the coils themselves may be ok. There's just something odd in manufacturing of that particular tank that allows the resistance to float. If you've already tried new coil heads and you're still having issues, it could be the tank.

    Possible solution: Try another tank, preferably one you know works on another mod, or use a dripper built with SS wire. I try to use a "known good" dripper to troubleshoot when I can.

    3) The mod itself is defective

    The good news is, that this is a fairly rare situation. Sometimes the soldiering inside the mod itself can be spotty. If it's "spotty" enough, the mod will be unable to make the required resistance measurements for TC to work. This could be the issue when you've tried multiple tanks that work on other mods (and possibly a TC dripper) and it still won't regulate. I've seen this happen only once in the years that I've been using TC.

    Solution: Get another mod. :(

    Hopefully this will help you isolate and fix your problem.
     
    Mad Scientist and trlrtrash13 like this.

Share This Page

  • About Us

    We are a forum that specializes in rebuildable atomizers and advanced personal vaporizers. Founded from the scrap pile of the late great Rebuildable E-cigs Forum, we continue on in our search for the perfect vape. We welcome new and experienced builders alike.